Joomla meta descriptions and Google supplementals

post I made to Joomla forum:

I'm late to see the problems with Google "supplemental hell" - in which many or most of a site's pages might be in Google's supplemental index, not the main index: seems to mean being rated as part of "dregs" of Internet, and only appearing in results when Google can't find much else (and the pages it does find can include spam, with near zero actual content).

One check for indexing w google is via site:www.domain.com - see how many pages indexed, and how many only appear when click link to omitted results. [Also, in search results, Google adds wording "supplemental result" by pages that are from supplemental index.]

Key cause w my pages is, I think, having identical meta descriptions. I got rather lazy as google etc paying not much attention to these, so didn't often bother with adding meta descriptions [and keywords] when creating new items. Meant that default was the site description. Didn't seem to matter; Google was pulling descriptions from page content.

Now, however, seems Google isn't reading pages too well; and seems to have strong tendency to figure that if description is same, the page must be the same. Might be a temporary glitch, or maybe not. (See, say, webmasterworld for umpteen posts from people who've suffered having loads of pages tossed into supplemental index.)

For regular items, can make changes - I've started working through, adding meta descriptions. But how about, say, for joomlaboard? My forum threads were doing well in searches - even with SE "unfriendly" URLs. Now, however, seems they are all in supplementals. Is there a hack that could readily take, say, thread title and make it meta description; much as thread title now used as meta page title? [and as I've just noticed here on this forum] Couple more points: - Many of my "pages" in supplemental index don't belong in any index; some are links to forum pages as posts being added; these no longer exist. - I've just tried cleaning up site URLs, also googlesitemap; might help a little, but not with joomlaboard I think. Wonder, too - anyone else experiencing same problems w Joomla site and Google? (and found cures) Mentioned in a thread here: http://forum.joomla.org/index.php/topic,5620.0.html (I've tried starting new thread as that one covers more general info re Google)

Forums: 
Share this