SEO and Simpleboard

Dr. Williams-

Thanks for the helpful posts and articles. I've found using Mambo can be a challenge, and your comments are well organized and thoughtful.

I'm using Mambo (4.5.2.3), Simpleboard (1.1.0 Stable), and Xaneon Extensions (2.0.0-beta2) on a site called www.ComplainAboutIt.com">http://www.ComplainAboutIt.com/]www.ComplainAboutIt.com[/url].

It is primarily a forum site, and I've had a heck of a time with duplicate url's within Simpleboard. I want to highlight the "lastest 5 posts" module, but it only shows the original url's. I tried to use Xaneon to create new URL's within Simpleboard, but it doesn't work.

Any ideas on how to get the "latest 5" to show either Mambo-generated or Xaneon-generated URL's?

Is there a hack out there to get the module to play nice with the other SEF components?

Regards,

Jeff complaints@complainaboutit.com Post complaints, help others, and learn about faulty products and services on www.ComplainAboutIt.com">http://www.ComplainAboutIt.com/]www.ComplainAboutIt.com[/url]

Forums: 
Share this

Hi Jeff:

Glad you find the posts and articles helpful; encouraging, so I'll see about expanding sometime.

But, till your post, I hadn't noticed re getting duplicate URLs from Simpleboard Latest 5 module - had focused elsewhere.

Now, however, I too see this problem. No idea re fix. Just maybe someone at tsmf forums will be able to help.
Though really, this is at least partly a Mambo issue: it seems to me that Mambo is now at stage at which could improve URL generating, including with better mechanism from component URLs.

In article about using menalto Gallery, I mention a fix for SEF URLs for this component, to work with Xaneon - not sure if could be adopted for Simpleboard (I'm clueless re coding).

If you have any success, maybe make a follow-up post.

Cheers,
Martin

Later thought:

wonder how important duplicate URLs issue is here.

For myself, I want Google to index threads, rather than individual posts. Not getting dupes for these.

then, only five posts a time, and if a forum's active (much more than this one!), no one post should be around for long.

Guessing somewhat; and after all, you mentioned it's a problem.

Martin-

You're correct, the latest 5 links are not a huge deal, since there are only 5 of them. It just dilutes the search experience, and from what I can tell, makes it more difficult for the search engines to figure out what the thread is about. (The latest 5 posts do link to threads, and not just the posts)

For example, I have some Geico-related complaint threads ([url=http://www.complainaboutit.com/complaints/func,view/id,267/catid,41/]see complain about Geico insurance[/url]), where Google can't figure out that this is an insurance-related page. Google keeps serving ads for the Chrysler 300C! Can't figure out why, except for the latest 5 link. I'm thinking about shutting it off until I can find a fix, just to eliminate it as a source of the problem.

I posted this question on the TSMF site, and rec'd an email from a guy saying he had a fix for it. If I receive it and it works, I will post it back here and let you know.

Regards,

Jeff